Forums

    4 posts

  • avatar
    0 sounds
    2 posts
    Site Freezes when playing clips


    Hi,

    When I click to play a clip through the javascript widget thing it doesn't play, and then the site locks up. In fact the whole browser locks up.

    Details: OS Linux Mint 14 Cinnamon 64 bit
    Browser: Firefox 21 (Firefox for Linux Mint 1.0)

  • avatar
    1913 sounds
    1743 posts


    gimpgimpgimp wrote:When I click to play a clip through the javascript widget thing it doesn't play, and then the site locks up. In fact the whole browser locks up.

    I think it's a flashplayer thing.
    If you don't have flashplayer installed, or have a flashblocker in your browser, the clips won't play.

    http://en.wikipedia.org/wiki/Flashplayer

  • avatar
    0 sounds
    2 posts


    I don't know I think it's more complicated than that. The issue seems to be some clash between Processing (of processing.org) and the browser. It's like there's a lock on the audio player or something. I tried the same thing in Chrome and its similar, but the site doesn't freeze, it just refuses to play. If I then close down Processing then the audio clip plays.

    Since I updated the version of Java in Processing I can't reproduce the issue. Hmm.

  • avatar
    1913 sounds
    1743 posts


    gimpgimpgimp wrote:
    ... The issue seems to be some clash between Processing (of processing.org) and the browser. It's like there's a lock on the audio player or something. I tried the same thing in Chrome and its similar, but the site doesn't freeze, it just refuses to play. If I then close down Processing then the audio clip plays.

    exclusive-mode ? ....

    microsoft.com wrote:
    ... if an application opens a stream in exclusive mode, the application has exclusive use of the audio endpoint device that plays or records the stream.
    http://msdn.microsoft.com/en-us/library/windows/desktop/dd370844%28v=vs.85%29.aspx

    4 posts